
Introduction to StressCheck® 

These slides complement the Getting Started Guide of StressCheck®. The 

step-by-step procedures of importing a Parasolid file, creating the mesh, 

entering input data, solving and post-processing are illustrated. 
 

Manual construction of a mesh for a parameterized plane elastic body and 

specification of parameterized loading are illustrated on the basis of 

Exercise 4.3.9. 



Introduction to StressCheck 

• Import a Parasolid file 

– Start StressCheck and make sure that the Reference/Theory 

Toolbar is displayed.  

• It is good practice to display all toolbars: Click on View and 

select  ALL Toolbars.  We will not need the Part/Assembly 

Toolbar, turn it off. 

– Select Planar / Elasticity / mm/N/sec/C 

• The type of analysis and units must be consistent with the 

Parasolid file. 

– Select File > Import 

• A reminder will be displayed. If you did not update the units as 

indicated above, do so before importing the file. 

• Using the browser import your Parasolid file. 

• In this example we will import NotchedBeam1.x_t 
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Create an automesh (1) 

• You should see the Parasolid sheet body 

shown below. 

 

 

 

• Select the icon       or click Alt – I.  This will 

take you to the StressCheck Input dialog box. 

• Click on the Mesh tab and set the scroll boxes 

at the top display to: Create/Mesh/Auto. 
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Create an automesh (2) 

• You will see the dialog box 

shown on the right. 

• Complete as shown and 

click on Accept.  This means 

that you have accepted the 

default meshing parameters. 

A meshing record will be 

created. 

• Click on Automesh.  This will 

produce the mesh of 6-node 

isoparametric elements 

shown in next slide. 
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Create an automesh (3) 

• The mesh shown below will appear 
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To zoom left click on the icon         and drag 

with the right button held. 
 

Zooming on the circular fillets you will see that 

the 90 – degree circular sector is 

approximated by only one element. 
 

Smaller elements will be created at the fillet if 

you select Create / Mesh / Curve then select 

both fillets, use default values in the mesh 

interface,  Accept  >  Automesh 



Enter input records (1) 

• The refined mesh is shown below 

 

 

 

• Assign the thickness 

– Select > All Elements 

– Enter the thickness (4.0) 

– Accept  
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Enter input records (2) 

• Material properties are entered in two steps.  
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Define Assign 



Enter input records (3) 

• Load records 

– Let us enter uniformly distributed loads 
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Select curve 

Specify direction 

Specify component and 

value then Accept 

Assign name of the load record 



• Constraint record 

–                    Let us enter a rigid body constraint record as 

shown on the shown in the figure on the left. 

 

 

 

 

 

Enter input records (4) 
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Rigid body constraint 

Select the two corner points as shown 

below and the rigid body constraint will 

be created automatically (no need to click 

on Accept). 



Enter input records (5) 

• Solution record 

– Associates the names of a 

constraint record (RB) and 

load record (UDL) with the 

name of a solution (SOL). 

– Click on Accept to create 

record. 
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Recommended exercise 

• In the preceding steps we first created the 

mesh then entered the input data. 

• We could have entered the input data then 

created the mesh. 

– In general it is good practice to associate the load 

and constraint records with geometric objects 

(points, curves) rather than with meshing objects 

(nodes, element edges or edge curves). 

• Enter the input data first then create the 

mesh. 

– The input data can be entered in any order.  
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Solution (1) 

• Click on the icon         or press Alt – S 

– You will see the solution tab below.  Fill in the 

range of p values (in this case 1 to 8) and click on 

Solve. 
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• You will see the second solution tab shown 

below.  

– Complete as shown and click on Solve. 

Solution (2) 
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Postprocessing (1) 

• Click on the icon       or press Alt - X 

• Select the Error tab, and complete the solution ID 

and run numbers, then Accept.   

– You will see a graph showing a the relative error in energy 

norm in the Chart tab, and you can select to see the tabular 

data in the Table tab. 
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Relative error in energy norm 
p N PE beta % err. 

1 415 -1.199360E+06 0 11.72 

2 1527 -1.215952E+06 1.93 0.95 

3 3335 -1.216057E+06 2.12 0.18 

4 5839 -1.216061E+06 2.51 0.04 

5 9039 -1.216061E+06 2.5 0.01 

6 12935 -1.216061E+06 2.25 0.01 

7 17527 -1.216061E+06 2.08 0 

8 22815 -1.216061E+06 2.08 0 



Postprocessing (2) 

• Click on the Plot tab 
– Select the solution record and run number that you wish to 

plot. Here p=8 was selected. 

– For a contour plot click Fringe. 

– Select the function to be plotted.  Here we selected Seq (the 

von Mises stress). 

– Specify the number of midsides. This determines the 

resolution of the data plot. Here 5 was selected. 
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Postprocessing (3) 

• Click on the Min/Max tab 
– Select the solution records p=1 to p=8. 

– Select the function of interest. Here we selected S1 (the first 

principal stress). 

– Specify the number of midsides. This determines the search 

grid. Here 9 was selected. Click on Accept and you will see 

the graph below. 
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Manual construction 

• Manual construction is recommended when a 

part is to be analyzed repeatedly, as in a 

design study. 

– The part is characterized by a set of parameters. 

– Example: See Exercise 4.3.9 in the text. 
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Manually constructed mesh 

• Example of a manually constructed mesh 

– The elements and the nodes are shown below 

 

 

 

 

– The name of the input file is NotchedBeam.sci 

– To read the input file click on the icon       then 

select the filename and double click on it. 

– We will construct this mesh step by step. 
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Enter the parameters 

• Click on the icon      and select the parameter 

tab. Enter the parameters. 

– Note that M2 depends on M1 and V. – Why? 
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Construct geometrical objects (1) 
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• Click on the icon       and 

select the geometry tab 

– Select Create > Rectangle 

> Locate 

• Enter parameters a, b as 

shown. 

• Click Accept, and the 

rectangle will appear. 

– Center rectangle by 

clicking on the icon 

• The global coordinate 

system is in the lower left 

corner of the rectangle. 



• Create a second rectangle 

using the parameters 

shown on the right. 

– The result is shown below. 

Construct geometrical objects (2) 
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• Create fillets 

– Specify radius (rf). 

– Click on each of the 

intersecting lines where you 

want the fillet inserted. 

– Points are created at the 

ends of the circular arc. 

Construct geometrical objects (3) 
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Construct mesh (1) 

• To construct a mesh first create the nodes 

then create the elements. Select Mesh. 

- Nodes can be created in several ways.  We will 

create nodes by  

- locating them where points already exist                 

Create > Node > Point  select the point(s) where you 

wish to locate nodes click accept 

- the mid-point method                                                 

Create > Node > Midpoint  click on the two nodes, a 

node will be created in the mid-point 

- projection  

 Create > Node > Projection select the node(s) you wish 

to project. Hold the Ctrl and Shift keys then click Accept. 
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• After turning off the Point and System 

displays you should see the figure below.  

– The labels pt, mp and pr indicate the point, mid-

point and projection methods 

Construct mesh (2) 
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Construct mesh (3) 

• Create elements:  

– Create > Quadrilateral >Selection 

– Click or select any four nodes.  A quadrilateral 

element will be created.   

– Alternatively hold Ctrl - Shift then bring the cursor 

near the centroid of the element you wish to 

create. A green outline will appear.  Left click and 

release Ctrl – Shift. 
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Check mesh & refine 

• Check for errors in meshing 

– Check > Edge > Free Edge.  The free edges will 

be highlighted. Troubleshoot if necessary. 

• Refine (read Example 7.3.1 in the text) 

– Click on the tab h-Discretization 

– Select > Edge Curve > Simple Graded 

– Name (any name), Layer (leave blank),  Midsides 

(1),  Grading (0.2) 

– Click on any edge on the cut-out, Accept, Mesh. 
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Define formulae 

• Click on the icon  

– Define formulae for the 

normal traction on the right 

(TNR), normal traction on 

the left (TNL) and the 

shearing traction (TT) as 

shown on the right. 

• Create a centroidal 

coordinate system 

– Geometry > Create > 

System > Locate 

    X = 0, Y = b/2, Z = 0  
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Apply load 

• Click the Load tab 

– Select > Any Curve > Traction 

– Click on the curve(s) to be 

loaded 

– ID: Any name (Tractions) 

– Direction: Norm/Tan 

– System: Select the system 

created in the previous step 

– Normal: Formula (TNR) 

– Tangent: Formula (TT) 

– Accept 
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Check equilibrium 

• Rigid body constraints should be applied only 

when the body is in equilibrium. – Why?  

• To check whether the applied loads satisfy 

equilibrium; 

– Check > All Elements > Selection > Accept 

– A report showing the net force components and 

moment acting on the body will appear.  These 

should be very nearly zero, that is, orders of 

magnitude smaller than max(|M1|, |M2|, V). 

– If the body is not in equilibrium then there is an 

error in input.  Trouble shoot. 
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Solution & post-processing 

• Enter the material properties, apply rigid body 

constraints and create the solution record. 

• Solve p = 1 to p = 8. 

• Extract the first principal stress.  You will see 

the results below.  At p=8 S1 = 205.7 MPa 
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Run DOF Max. S1 

1 63 1.9900E+02 

2 167 2.0010E+02 

3 271 2.1100E+02 

4 415 2.1460E+02 

5 599 2.0910E+02 

6 823 2.0810E+02 

7 1087 2.0670E+02 

8 1391 2.0570E+02 



• Modify the record for h-Discretization so that 

Midsides = 2, Grading = 0.3 and click on 

Mesh. You will see the mesh shown below: 

 

 

 

• Solve again and extract the maximum value 

of the first principal stress. At p = 8 you will 

find it to be 204. 5 MPa. 

Modifying the mesh 

31 



Extrude 

• If you have access to the Professional Edition 

of StressCheck then you can convert this 

planar problem to a 3-dimensional one by 

extrusion.  

• Let us impose constant moment on the 

boundaries BC and DA determine the value 

of the moment that will cause an out of plane 

displacement of 2.0 mm. 
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• Select Extrude (Reference/Theory 

toolbar). 

– You you will see the body shown below. 

Extrusion 
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Define the normal traction 

• Define formula for the 

normal traction Tn 

corresponding to a unit 

moment. 

– Enter the formula shown 

on the right. 

– Click Accept 
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Apply tractions 

• Apply unit moment 

– Select Face Surface, enter ID 

(UnitMoment), Direction: 

(Norm/Tan), Normal: Tn 

Accept. 

– Repeat for the opposite side 

– Check equilibrium. 
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Create solution record 

• StessCheck automatically 
converted the rigid body 
constraints to 3D. 

• Create a new solution record 
– Solution ID (Sol_M) 

– Constraint Record (RB) 

– Load Record (UNITMOMENT) 

• Solve 
– Since there are two active 

solution records, there will be 
two solutions. 
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Display the deformed configuration 

• Plot the deformed 

configuration 

• Find the maximum 

displacement Uz: 

– (Uz)max = 4.369E-4 mm 

– The moment that will 

cause 2 mm maximum 

displacement is therefore 

M = 4578 Nmm. 
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Recommended exercises 

• Determine the maximum von Mises stress in 

the extruded configuration corresponding to the 

applied moment of 4578 Nmm and verify that 

the relative error is not greater than 2 %. 

– Answer: 119.8 MPa. 

• Compare the maximum normal stresses 

computed for (a) the two dimensional body and 

(b) the extruded body loaded in-plane only. 

– Answer: (a)  204.5 MPa    (b) 189.6 MPa 

– Note: For answer (a) see p. 31. 

– Note: The location of the maximum is the same for 

(a) and (b): x = 112.8 mm, y= 5.88 mm. 
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Recommended exercises 

• Import the file NotchedBeam1.x_t 

• Create the parameters 

 

 

 

 

• Create a circle with center (x0,y0), radius r0 

• Use Boolean subtraction to create the sheet body; 

 

 

 

• Construct an isoparametric mesh (automesh). 
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Recommended exercises 

• Using the default parameters you should see a mesh 

like this: 

 

 

 

• Using the default refinement at the curved boundary 

segments, you should see a mesh like this: 

 

 

 

• What will happen if you change the parameters that 

define the circular hole? 
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